Google berkomitmen untuk mendorong terwujudnya keadilan ras bagi komunitas Kulit Hitam. Lihat caranya.

Persyaratan Sniffing Paket

Lihat sumber di GitHub

Untuk menggunakan Pyspinel, Anda harus memenuhi persyaratan hardware dan software berikut.

Hardware

  • Mesin host yang berfungsi sebagai NCP dan untuk menjalankan Pyspinel dan Wireshark:

    • macOS — OS 64 bit X 10.6 atau yang lebih baru
    • Linux
    • Windows — 10 atau yang lebih baru
  • 1 perangkat OpenThread yang di-flash dengan build ot-ncp-ftd atau ot-rcp.

    • Untuk build ot-ncp-ftd, tombol build LINK_RAW=1 harus digunakan.

Perangkat lunak:

  • Python 3 untuk menjalankan Pyspinel
  • Wireshark

    • 2.4.1 atau yang lebih baru untuk dukungan protokol Thread
    • 3.0.6 atau yang lebih baru untuk dukungan extcap. Untuk informasi selengkapnya tentang penggunaan plugin extcap Wireshark dengan Pyspinel, lihat Menginstal Pyspinel.