Exigences relatives à la détection de paquets

Afficher la source sur GitHub

Pour utiliser Pyspinel, vous devez répondre aux exigences matérielles et logicielles suivantes.

Matériel

  • Une machine hôte qui servira de NCP, et qui exécutera Pyspinel et Wireshark:

    • macOS : 64 bits, OS X 10.6 ou version ultérieure
    • Linux
    • Windows : 10 ou ultérieur
  • 1 appareil OpenThread clignote avec une compilation ot-ncp-ftd ou ot-rcp.

    • Pour un build ot-ncp-ftd, le contacteur de build LINK_RAW=1 doit être utilisé.

Logiciels :

  • Python 3 pour exécuter Pyspinel
  • Wireshark

    • 2.4.1 ou version ultérieure pour la compatibilité avec le protocole Thread
    • 3.0.6 ou version ultérieure pour la compatibilité extcap. Pour plus d'informations sur l'utilisation du plug-in extcap Wireshark avec Pyspinel, consultez la section Installer Pyspinel.