Requisiti per lo sniffing dei pacchetti

Visualizza sorgente su GitHub

Per utilizzare Pyspinel, devi soddisfare i requisiti hardware e software indicati di seguito.

Hardware

  • Una macchina host che funge da NCP ed esegue Pyspinel e Wireshark:

    • macOS: 64 bit OS X 10.6 o versioni successive
    • Linux
    • Windows - 10 o versioni successive
  • 1 Dispositivo OpenThread lampeggiato con una build ot-ncp-ftd o ot-rcp.

    • Per una build ot-ncp-ftd è necessario utilizzare l'opzione di build LINK_RAW=1.

Software:

  • Python 3 per eseguire Pyspinel
  • Squali Wire

    • 2.4.1 o versioni successive per il supporto del protocollo Thread
    • 3.0.6 o versione successiva per il supporto extcap. Per ulteriori informazioni sull'utilizzo del plug-in Wireshark extcap con Pyspinel, consulta Installa Pyspinel.